Blocks
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6378 Accepted: 3070
Description
Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.
Input
The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.
Output
For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.
Sample Input
2
1
2
Sample Output
2
6
染到第 i 个方案时,红绿都为偶数的方案数位 ai,红绿恰有一个是偶数的方案数为 bi,红绿都是奇数的方案数为ci,这样,染到第 i + 1 个方块时,红绿都为偶数的防暑有如下两种可能:
1)到第i个方块时红绿都为偶数,并且第 i + 1 个方块染成 蓝色或黄色;
2)到第i个方块时红绿恰有一个为奇数,并且第 i + 1 个方块染成奇数个数对应的那种颜色~~所以有以下递推式~~
a i + 1 = 2 * ai + bi;
同样有~
bi + 1 = 2 * ai + 2 * bi + 2 * ci;
ci + 1 = bi + 2 * ci;
转换成矩阵表示有 ~
|ai+1| |2 1 0||ai|
|bi+1| |2 2 2||bi|
|ci+1| |0 1 2||ci|
附上两种矩阵快速幂的实现代码~~~
vector~~(64ms)
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
typedef vector <int> v;
typedef vector <v> vl;
typedef long long LL;
const int mod = 1e4 + 7;
vl mul(vl &A,vl &B){
vl C(A.size(),v(B[0].size()));
for(int i = 0 ; i < A.size(); i++)
for(int k = 0 ; k < B.size() ; k++)
for(int j = 0 ; j < B[0].size() ; j++)
C[i][j] = (C[i][j] + A[i][k] * B[k][j]) % mod;
return C;
}
vl KSM(vl A,LL N){
vl B(A.size(),v(A.size()));
for(int i = 0 ; i < A.size(); i++) B[i][i] = 1;
while(N > 0){
if(N & 1) B = mul(B,A);
A = mul(A,A);
N >>= 1;
}
return B;
}
int main()
{
LL N,T;
scanf("%lld",&T);
while(T--){
scanf("%lld",&N);
vl A(3,v(3));
A[0][0] = 2; A[0][1] = 1; A[0][2] = 0;
A[1][0] = 2; A[1][1] = 2; A[1][2] = 2;
A[2][0] = 0; A[2][1] = 1; A[2][2] = 2;
A = KSM(A,N);
printf("%d\n",A[0][0]);
}
return 0;
}
结构体~~(这种时间稍微快一点点0ms)
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long LL;
const int mod = 1e4 + 7;
struct node{
int z[3][3];
}A,B;
node mul(node a,node b){
node C;
for(int i = 0 ; i < 3 ; i++)
for(int j = 0 ; j < 3 ; j++){
C.z[i][j] = 0;
for(int k = 0 ; k < 3 ; k++)
C.z[i][j] = (C.z[i][j] + a.z[i][k] * b.z[k][j]) % mod;
}
return C;
}
node KSM(LL N){
while(N){
if(N & 1)
B = mul(B,A);
A = mul(A,A);
N >>= 1;
}
return B;
}
int main()
{
LL N,T;
scanf("%lld",&T);
while(T--){
scanf("%lld",&N);
A.z[0][0] = 2; A.z[0][1] = 1; A.z[0][2] = 0;
A.z[1][0] = 2; A.z[1][1] = 2; A.z[1][2] = 2;
A.z[2][0] = 0; A.z[2][1] = 1; A.z[2][2] = 2;
for(int i = 0 ; i < 3 ; i++)
for(int j = 0 ; j < 3 ; j++)
if(i == j) B.z[i][j] = 1;
else B.z[i][j] = 0;
A = KSM(N);
printf("%d\n",A.z[0][0]);
}
return 0;
}
本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。