Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
Write a program that can verify the results of the game.
Line 1: A single integer, P
Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2
考虑它的操作类似于集合的合并,所以考虑并查集。
在基础并查集的基础上加入两个数组:一个记录该集合中元素的个数;一个记录该集合中在i盒子上面的盒子个数。询问时相减(再减一)即可得到答案。
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int maxn=30010;
int father[maxn];
int r[maxn];//当前编号盒子上方的盒子数(到根的距离)
int mx[maxn];//集合元素数
int p;
void init()
{
for(int i=1;i<maxn;++i){
father[i]=i;;
mx[i]=1;
r[i]=0;
}
}
int getfather(int x)
{
//if(x!=father[x]) return father[x]=getfather(father[x]);
int fx=father[x];
if(father[x]!=x){
fx=getfather(father[x]);
r[x]+=r[father[x]];//在压缩路径时,累加到根的距离
}
return father[x]=fx;
}
void Union(int x,int y)
{
int xx=getfather(x);
int yy=getfather(y);
if(xx!=yy){
father[yy]=xx;
}
r[yy]+=mx[xx];//到根的距离增加
mx[xx]+=mx[yy];//数量增加
}
int main()
{
ios::sync_with_stdio(false);
char ch;
int u,v;
while(cin>>p)
{
init();
while(p--)
{
cin>>ch;
if(ch=='C'){
int f;
cin>>u;
f=getfather(u);
cout<<mx[f]-r[u]-1<<endl;
}
else{
cin>>u>>v;
Union(u,v);
}
}
}
return 0;
}
本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。