Leading and Trailing LightOJ - 1282(数论)


Leading and Trailing

LightOJ - 1282

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.


Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

题意:给你两个数n,k让你求n^k的前三位和后三位
思路:
后三位很好求就是直接快速幂取模1000即可,主要要输出后三位,所以如果有022这种情况,也要输出0,%03d就可以解决了。
主要说一下前三位的求法,我们根据公式推导一下
我们知道对于任意一个数可以表示成科学计数法就是 a.bcd * 10^m
所以就有了 n^k = a.bcd * 10^m
这是我们发现了只要我们能得到a.bcd这部分小数,然后乘100取整即可
两边取10的对数lg得:
k * lg(n) = lg(a.bcd * 10^m) = lg(a.bcd) + m;
我们设x = lg(a.bcd),所以10^x = a.bcd,所以我们只需要求出x即lg(a.bcd)
lg(a.bcd) = k * lg(n) - m = k * lg(n) - (int)k * lg(n);
所以这么退出来了
lg(a.bcd) = k * lg(n) - m = k * lg(n) - (int)k * lg(n) 这一串,直接使用cmath中的log10函数求就好了;
这里我们再介绍cmath中的函数

使用fmod(a, 1)表示求浮点型数 a 的小数部分

 原型:extern float fmod(float x, float y)
 用法:#include <math.h>
 功能:计算x/y的余数
 说明:返回x-n*y,符号同y。n=[x/y](向离开零的方向取整),如:fmod(f,(int)f)即可得到小数点后的部分

直接求出lg(a.bcd)
太神奇了!!


code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
const ll mod = 1000;
ll q_pow(ll a,ll b){
    ll ans = 1LL;
    while(b){
        if(b & 1){
            ans = ans * a % mod;
        }
        a = a * a % mod;
        b >>= 1;
    }
    return ans;
}
int main(){
    int t,cas = 0;
    scanf("%d",&t);
    while(t--){
        ll n,k;
        scanf("%lld%lld",&n,&k);
        ll least = q_pow(n,k);
        //double x = 1.0 * k * log10(n * 1.0) - (int)(1.0 * k * log10(n * 1.0));
        double m = pow(10,fmod(1.0 * k * log10(n * 1.0),1.0));
        printf("Case %d: %d %03d\n",++cas,(int)(m*100.0),least);
    }
    return 0;
}



智能推荐

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



猜您在找
【LightOJ1282】Leading and Trailing(数论) Leading and Trailing LightOJ - 1282 题解 E - Leading and Trailing LightOJ - 1282 lightoj 1282 - Leading and Trailing 【数学】 LightOJ 1282 Leading and Trailing (数学)
智能推荐
 
© 2014-2019 ITdaan.com 粤ICP备14056181号  

赞助商广告