E - Leading and Trailing LightOJ - 1282


题目链接点击打开链接

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107).

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669


题意,求出n的k次幂前三位和后三位。

后三位由快速幂,前三位可由数学公式推导。

n的k次幂我们用科学记数法表示则a*10的m次方,两边同时取对数

得k*log10(n)=log10(a)+m。这里可以发现m为k*log10(n)得整数部分(因为a大于0小于10,取对数后为0.xxx形式),

所以可求得log10(a),这里求前三位故加2(相当于乘100),算10得次方既可。

code:

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define mod 1000
LL quick_pow(LL x,int k)
{
    LL ans=1;
    while(k>0)
    {
        if(k&1)
        {
            ans*=x;
            ans%=mod;
        }
        x*=x;
        x%=mod;
        k>>=1;
    }
    return ans;
}


int main()
{
    int T;
    scanf("%d",&T);
    for(int c= 1; c<=T; c++)
    {
        int k,i;
        LL n;
        scanf("%lld %d",&n,&k);
        double temp=k*log10(n);
       temp=fmod(temp,1);
       int res=(int)(pow(10,temp)*100);
        printf("Case %d: %03d %03lld\n",c,res,quick_pow(n,k));
    }
}

智能推荐

注意!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系我们删除。



 
China Scenic Area
© 2014-2019 ITdaan.com 粤ICP备14056181号  

赞助商广告